Skip to main content

Troubleshooting in CodeTogether Live

When troubleshooting issues in CodeTogether Live, a Debug Log can be helpful.


Viewing the Debug Log in IntelliJ​

  1. Select Help > Diagnostic Tools > Debug Log Settings.

  2. Add codetogether.connection:all to the list.

  3. Click OK.

  4. Restart IntelliJ.

  5. Start a new CodeTogether session.

  6. Choose Help > Show Log in Explorer/Finder.

  7. Open the idea.log file and search for entries containing codetogether.connection.


Viewing the Debug Log in Eclipse​

  1. Close Eclipse.

  2. Edit the eclipse.ini file. It is usually next to your Eclipse IDE executable.

  3. Add the following property below the -vmargs line: -Dcodetogether.trace=true

  4. Save the file.

  5. Launch Eclipse from the command line: Windows: eclipse.exe -console -consolelog Linux/macOS: ./eclipse -console -consolelog

  6. Start a new CodeTogether session.

  7. View the log in the Terminal view.


Viewing the Debug Log in VS Code​

  1. Open the command palette (Ctrl+Shift+P) and type >CodeTogether Live: Open Settings.

  2. Click the Workspace tab.

  3. Under CodeTogether: Debug, select the Enable debug logging check box.

  4. Start a new CodeTogether session.

  5. Select View>Output.

  6. Click the drop down arrow and select CodeTogether Live to view the log.